Details

    • Type: Bug
    • Status: Done
    • Priority: Low
    • Resolution: Done
    • Affects Version/s: GDP-ivi9
    • Fix Version/s: None
    • Component/s: GDP Master
    • Labels:
    • Sprint:
      2425_Angler, 2627_Can-cell

      Description

      Since the upgrade to gdp-ivi9, specifically it seems the switch to weston 1.9 + extension 1.9 the gfx performance of the QEMU image seems to have taken a hit, when executing the KVM with the same flags. The transition animation when the hmi-launcher carousel moves seems to be dropping frames. The KVM execution command may need tweaking to provision extra host resources.

        Attachments

          Issue Links

            Activity

            Hide
            toscalix Agustin Benito Bethencourt added a comment -

            Transition: Issue assigned to Zeeshan Ali

            Show
            toscalix Agustin Benito Bethencourt added a comment - Transition: Issue assigned to Zeeshan Ali
            Hide
            gandersson Gunnar Andersson added a comment -

            Corresponding PR link: meta-genivi-dev:#34

            Show
            gandersson Gunnar Andersson added a comment - Corresponding PR link: meta-genivi-dev:#34
            Hide
            gandersson Gunnar Andersson added a comment - - edited

            PR converted to apply to genivi-dev-platform instead: genivi-dev-platform:#96
            (the old link above is still useful for the comments)

            Show
            gandersson Gunnar Andersson added a comment - - edited PR converted to apply to genivi-dev-platform instead: genivi-dev-platform:#96 (the old link above is still useful for the comments)
            Hide
            gandersson Gunnar Andersson added a comment -

            PR built OK (in particular for QEMU). Now time to test.

            Show
            gandersson Gunnar Andersson added a comment - PR built OK (in particular for QEMU). Now time to test.
            Hide
            gandersson Gunnar Andersson added a comment -

            Qemu is still launched differently on different distros and I had difficulty confirming the fix.
            poky runqemu script can be helpful but only works properly if run in a yocto build directory - not really practical when having only an image + kernel. With runqemu, it still requires us to add some special qemu parameters to the call. Therefore whole setup and the instruction page needs more work to give good guidance how to run.

            Show
            gandersson Gunnar Andersson added a comment - Qemu is still launched differently on different distros and I had difficulty confirming the fix. poky runqemu script can be helpful but only works properly if run in a yocto build directory - not really practical when having only an image + kernel. With runqemu, it still requires us to add some special qemu parameters to the call. Therefore whole setup and the instruction page needs more work to give good guidance how to run.

              People

              • Assignee:
                gandersson Gunnar Andersson
                Reporter:
                tom.pollard Tom Pollard
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: