Details

    • Type: Bug
    • Status: Done
    • Priority: Medium
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:

      Description

      Recent build produce (sometimes) a task hash mismatch error

      This commit appears to fix the issue, creating a PR for that purpose
      http://git.yoctoproject.org/cgit/cgit.cgi/meta-raspberrypi/commit/?id=4c02c7ce07121c2f5367204445f93199d828bb10

      The errors don't affect the build but the number of errors worry anyone doing the build

        Attachments

          Issue Links

            Activity

            Show
            rajm Robert Marshall added a comment - PR created https://github.com/GENIVI/genivi-dev-platform/pull/45
            Hide
            rajm Robert Marshall added a comment - - edited

            And added https://github.com/GENIVI/meta-genivi-dev/pull/38 to cover the README.md

            Show
            rajm Robert Marshall added a comment - - edited And added https://github.com/GENIVI/meta-genivi-dev/pull/38 to cover the README.md
            Hide
            rajm Robert Marshall added a comment -

            And it affects more builds than just the raspberrypi

            Show
            rajm Robert Marshall added a comment - And it affects more builds than just the raspberrypi
            Hide
            rajm Robert Marshall added a comment -

            There's another meta-rpi update which claims to solve this, I had to also update meta-oe but then get build failures updated poky and then get
            WARNING: rust-llvm-native-1.7.0-r0 do_populate_lic: Could not copy license file /yocto/GDP/clean/raspPi3/genivi-dev-platform/gdp-src-build/tmp/work-shared/rust-1.7.0-r0/rustc-1.7.0/src/llvm/LICENSE.TXT to /yocto/GDP/clean/raspPi3/genivi-dev-platform/gdp-src-build/tmp/work/x86_64-linux/rust-llvm-native/1.7.0-r0/license-destdir/rust-llvm-native/LICENSE.TXT: [Errno 2] No such file or directory: '/yocto/GDP/clean/raspPi3/genivi-dev-platform/gdp-src-build/tmp/work-shared/rust-1.7.0-r0/rustc-1.7.0/src/llvm/LICENSE.TXT'
            ERROR: rust-llvm-native-1.7.0-r0 do_install: oe_runmake failed
            ERROR: rust-llvm-native-1.7.0-r0 do_install: Function failed: do_install (log file is located at /yocto/GDP/clean/raspPi3/genivi-dev-platform/gdp-src-build/tmp/work/x86_64-linux/rust-llvm-native/1.7.0-r0/temp/log.do_install.25281)
            ERROR: Logfile of failure stored in: /yocto/GDP/clean/raspPi3/genivi-dev-platform/gdp-src-build/tmp/work/x86_64-linux/rust-llvm-native/1.7.0-r0/temp/log.do_install.25281
            Log data follows:

            DEBUG: Executing shell function do_install
            NOTE: make -j 8 DESTDIR=/yocto/GDP/clean/raspPi3/genivi-dev-platform/gdp-src-build/tmp/work/x86_64-linux/rust-llvm-native/1.7.0-r0/image install
            make: *** No rule to make target 'install'. Stop.
            WARNING: exit code 1 from a shell command.
            ERROR: oe_runmake failed
            ERROR: Function failed: do_install (log file is located at /yocto/GDP/clean/raspPi3/genivi-dev-platform/gdp-src-build/tmp/work/x86_64-linux/rust-llvm-native/1.7.0-r0/temp/log.do_install.25281)

            The failure without updating poky is covered here https://www.mail-archive.com/yocto@yoctoproject.org/msg31664.html

            Show
            rajm Robert Marshall added a comment - There's another meta-rpi update which claims to solve this, I had to also update meta-oe but then get build failures updated poky and then get WARNING: rust-llvm-native-1.7.0-r0 do_populate_lic: Could not copy license file /yocto/GDP/clean/raspPi3/genivi-dev-platform/gdp-src-build/tmp/work-shared/rust-1.7.0-r0/rustc-1.7.0/src/llvm/LICENSE.TXT to /yocto/GDP/clean/raspPi3/genivi-dev-platform/gdp-src-build/tmp/work/x86_64-linux/rust-llvm-native/1.7.0-r0/license-destdir/rust-llvm-native/LICENSE.TXT: [Errno 2] No such file or directory: '/yocto/GDP/clean/raspPi3/genivi-dev-platform/gdp-src-build/tmp/work-shared/rust-1.7.0-r0/rustc-1.7.0/src/llvm/LICENSE.TXT' ERROR: rust-llvm-native-1.7.0-r0 do_install: oe_runmake failed ERROR: rust-llvm-native-1.7.0-r0 do_install: Function failed: do_install (log file is located at /yocto/GDP/clean/raspPi3/genivi-dev-platform/gdp-src-build/tmp/work/x86_64-linux/rust-llvm-native/1.7.0-r0/temp/log.do_install.25281) ERROR: Logfile of failure stored in: /yocto/GDP/clean/raspPi3/genivi-dev-platform/gdp-src-build/tmp/work/x86_64-linux/rust-llvm-native/1.7.0-r0/temp/log.do_install.25281 Log data follows: DEBUG: Executing shell function do_install NOTE: make -j 8 DESTDIR=/yocto/GDP/clean/raspPi3/genivi-dev-platform/gdp-src-build/tmp/work/x86_64-linux/rust-llvm-native/1.7.0-r0/image install make: *** No rule to make target 'install'. Stop. WARNING: exit code 1 from a shell command. ERROR: oe_runmake failed ERROR: Function failed: do_install (log file is located at /yocto/GDP/clean/raspPi3/genivi-dev-platform/gdp-src-build/tmp/work/x86_64-linux/rust-llvm-native/1.7.0-r0/temp/log.do_install.25281) The failure without updating poky is covered here https://www.mail-archive.com/yocto@yoctoproject.org/msg31664.html
            Hide
            rajm Robert Marshall added a comment -

            Here's a branch for the meta-gd change to get a bitbake past the oe update
            https://github.com/RobertAJMarshall/meta-genivi-dev/tree/rpi/gpsd-fix
            I won't add the gdp change but I did
            git submodule update --remote meta-openembedded poky meta-raspberrypi

            as the previous comment says this doesn't get it to build

            Show
            rajm Robert Marshall added a comment - Here's a branch for the meta-gd change to get a bitbake past the oe update https://github.com/RobertAJMarshall/meta-genivi-dev/tree/rpi/gpsd-fix I won't add the gdp change but I did git submodule update --remote meta-openembedded poky meta-raspberrypi as the previous comment says this doesn't get it to build
            Hide
            rajm Robert Marshall added a comment -

            There's a meta-rpi branch for krogoth which carries the fix, I'll PR a fix next week!

            Show
            rajm Robert Marshall added a comment - There's a meta-rpi branch for krogoth which carries the fix, I'll PR a fix next week!
            Hide
            Leonanavi Leon Anavi added a comment -

            Hi,

            I experience the same issue today while I was working on a fix for Weston for Raspberry Pi. I was using the master branch of GDP. Is there any progress with this task?

            Best regards,
            Leon

            Show
            Leonanavi Leon Anavi added a comment - Hi, I experience the same issue today while I was working on a fix for Weston for Raspberry Pi. I was using the master branch of GDP. Is there any progress with this task? Best regards, Leon

              People

              • Assignee:
                toscalix Agustin Benito Bethencourt
                Reporter:
                rajm Robert Marshall
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: