Uploaded image for project: 'OSS Infrastructure'
  1. OSS Infrastructure
  2. OSSINFR-30

Cloning over git:// is failing from git.projects.genivi.org

    Details

    • Type: Technical Task
    • Status: Done (View Workflow)
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.1
    • Labels:
      None

      Description

      'fatal: read error: Connection reset by peer' when cloning any repo on the genivi git server over the git protocol (confirmed by many users)

      For one off clones switching to http:// is fine, however genivi has lots of hardcoded recipes that are reliant on git:// and http:// is not a drop in replacement to yocto recipes. As it stands the GDP is unbuildable from scratch

      Do we need to contact the LF admins?

        Attachments

          Issue Links

            Activity

            Farwell Josh Farwell added a comment -

            Hello Folks,

            I'm Josh Farwell, I work at LFIT.

            I was able to replicate the issues with cloning via git://. I believe it has something to do with how we are configuring xinetd and perhaps issues with load or concurrent connections.

            For now, the git:// protocol is working and I will continue to troubleshoot the problem. Please report back here and/or email helpdesk@rt.linuxfoundation.org if something changes.

            Thank you,

            – Josh Farwell
            jfarwell@linuxfoundation.org

            Gunnar Gunnar Andersson added a comment -

            I ran the testing script again for a few hours, at two different times.

            Starting Wed Apr 20 11:12:53 EDT, approximately 2.5 hours
            and
            Starting Thu Apr 21 00:48:43 EDT, several hours

            No errors logged so it looks like it is stable now.

            jeremiah.foster Jeremiah Foster added a comment -

            I note that there are a number of updates to the LF infrastructure recently and unplanned downtime in the next few days.

            Gunnar Gunnar Andersson added a comment -

            Ran the test script and found it to be stable also today

            between approximately Mon May 9 10:45:00 EDT -> Mon May 9 11:31:49 EDT

            I would propose to say it is now fine and close the ticket.

            admin Joel Replogle [Administrator] added a comment -

            Sounds good. Please re-open (or create new ticket) if git fails again.


              People

              • Assignee:
                admin Joel Replogle [Administrator]
                Reporter:
                tom.pollard Tom Pollard
              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: