Skip to end of metadata
Go to start of metadata

Introduction

This document contains detailed instructions for installing the SDK for the GENIVI Demo Platform (GDP-ivi7 - outdated version - see parent page) and setting up the development environment.

Setup SDK

This section describes how to install the GDP-ivi7 SDK, sysroots and Eclipse.
Please refer to the Yocto Project Development Manaual for more details.

Download GDP SDK Installer

  1. Download GDP SDK Installer from following link.
    Under development
  2. The following files need to be downloaded
    oecore-x86_64-core2-64-toolchain-nodistro.0.sh
    oecore-x86_64-cortexa15hf-vfp-neon-toolchain-nodistro.0.sh
    

    For setting up the SDK for the virtual machine (QEMU) in addition download the following files:

    bzImage-qemux86-64.bin
    genivi-demo-platform-qemux86-64.tar.bz2
    
  3. Download .sha512 file from upper link to verify the images integrity
    GDP_SDK_installer.sha512
  4. Execute the following command to check the SHA512 (512-bit) checksums. In case of a checksum failure (FAILED) is reported, try to re-download the file and re-run the check.
    $ cd $HOME/Downloads
    $ sha512sum --check GDP_SDK_installer.sha512
    bzImage-qemux86-64.bin: OK
    genivi-demo-platform-qemux86-64.tar.bz2: OK
    oecore-x86_64-core2-64-toolchain-nodistro.0.sh: OK
    oecore-x86_64-cortexa15hf-vfp-neon-toolchain-nodistro.0.sh: OK
    

Build GDP SDK Installer from source code

  1. Get GDP source code. Please refer to either Hardware Setup and Software Installation (QEMU) or Hardware Setup and Software Installation (PORTER/KOELSCH)
  2. Execute from step (1) to (5) of the "Build from Source Code" section of the Hardware Setup and Software Installation guide.
  3. Confirm the correct MACHINE is set in $BUILDDIR/conf/local.conf:
    MACHINE = "qemux86-64"
    
  4. make GDP image
    $ bitbake genivi-demo-platform
    
  5. Execute the following command for building the GDP SDK Installer
    $ bitbake genivi-demo-platform-sdk -c populate_sdk
    
  6. Repeat the above steps for
    MACHINE = "koelsch"
    
  7. Copy the files needed in the next steps to $HOME/Downloads
    $ cd $BUILDDIR/tmp/deploy/images/qemux86-64/
    $ cp bzImage-qemux86-64.bin $HOME/Downloads/
    $ cp genivi-demo-platform-qemux86-64.tar.bz2 $HOME/Downloads/
    $ cp oecore-x86_64-core2-64-toolchain-nodistro.0.sh $HOME/Downloads/
    $ cp oecore-x86_64-cortexa15hf-vfp-neon-toolchain-nodistro.0.sh $HOME/Downloads/
    

Install the GDP SDK Tool chain

  1. Goto folder into which to install the GDP SDK:
    $ cd $HOME
    
  2. Install the tool chain to build software for the virtual QEMU machine:
    $ $HOME/Downloads/oecore-x86_64-core2-64-toolchain-nodistro.0.sh -d ./gdp-sdk/qemux86-64
    
    You are about to install the SDK to "./gdp-sdk/qemux86-64". Proceed[Y/n]?
    Extracting SDK...done
    Setting it up...done
    SDK has been successfully set up and is ready to be used.
    
  3. Install the tool chain to build software for the Koelsch board
    $ $HOME/Downloads/oecore-x86_64-cortexa15hf-vfp-neon-toolchain-nodistro.0.sh -d ./gdp-sdk/koelsch
    
    You are about to install the SDK to "./gdp-sdk/koelsch". Proceed[Y/n]?
    Extracting SDK...done
    Setting it up...done
    SDK has been successfully set up and is ready to be used.
    

Extract QEMU sysroot

  • Extract the ivi-image-demo root file system tarball for using user-space NFS server to (later) boot the virtual machine (QEMU) with:
    $ cd $HOME/gdp-sdk/qemux86-64
    $ source environment-setup-core2-64-poky-linux
    $ runqemu-extract-sdk $HOME/Downloads/genivi-demo-platform-qemux86-64.tar.bz2 ./sysroots/genivi-demo-platform
    

Setup Eclipse™

The following section is an extract from the Yocto Project Development Manual that is licensed under the terms of the Creative Commons Attribution-Share Alike 2.0 UK: England & Wales as published by Creative Commons.

Install Eclipse™ and Yocto plugin

It is recommended that you have the Kepler 4.3 version of the Eclipse IDE installed on your development PC.
It is mandatory that a JDK is installed on the development PC. (e.g. Ubuntu sudo apt-get install openjdk-7-jdk)

  1. Download Kepler version of the Eclipse Standard 4.3.2 (64-bit version for Linux) or later 4.3 versions.
  2. Once you have downloaded the tarball, extract it into a clean directory.
    Following command will install Eclipse to $HOME/eclipse directory.
    $ cd $HOME
    $ tar xf  $HOME/Downloads/eclipse-standard-kepler-SR2-linux-gtk-x86_64.tar.gz
    
  3. Start and configure the Eclipse IDE
    The following section is based on the Yocto Project Development Manual chapter – Configuring the Eclipse IDE
    1. Change into the $HOME/eclipse folder and run the './eclipse' binary.
    2. In Eclipse select "Install New Software" from the "Help" menu.
    3. Select "Kepler - http://download.eclipse.org/releases/kepler" from the "Work with:" pull-down menu.
    4. Expand "Linux Tools" and select the "LTTng - Linux Tracing Toolkit".
    5. Expand "Mobile and Device Development" and select the following boxes:
      • C/C++ Remote Launch
      • Remote System Explorer End-user Runtime
      • Remote System Explorer User Actions
      • Target Management Terminal
      • TCF Remote System Explorer add-in
      • TCF Target Explorer
    6. Expand "Programming Languages" and select the "C/C++ Autotools Support" and "C/C++ Development Tools".
    7. Complete the installation and restart the Eclipse IDE.

     

      

  4. Installing the Pre-built Plug-in from the Yocto Project Eclipse Update Site
    1. In Eclipse, select "Install New Software" from the "Help" menu.
    2. Click "Add..." in the "Work with:" area.
    3. Enter http://downloads.yoctoproject.org/releases/eclipse-plugin/1.6.1/kepler/ for GDP7 or Enter http://downloads.yoctoproject.org/releases/eclipse-plugin/1.7.2/kepler/ for GDP8 in the URL field.
    4. Check the boxes next to "Yocto Project ADT Plug-in", "Yocto Project Bitbake Commander Plug-in", and "Yocto Project Documentation plug-in".
    5. Complete the remaining software installation steps, acknowledge the warning and then restart the Eclipse IDE.

     

     

Specify Toolchain and Sysroot

QEMU
  1. Choose "Preferences" from the "Windows" menu to display the Preferences Dialog.
  2. Click "Yocto Project ADT"
  3. Choose "Standalone pre-built toolchain" under "Cross Compiler Options".
  4. Point to "$HOME/gdp-sdk/qemux86-64" (expand $HOME while you do it) as "Toolchain Root Location.
  5. Point to "$HOME/gdp-sdk/qemux86-64/sysroots/genivi-demo-platform" (expand $HOME while you do it) as "Sysroot Location.
  6. Choose "QEMU" under "Target Options"
  7. Point to "$HOME/Downloads/bzImage-qemux86-64.bin" (expand $HOME while you do it) as "Kernel"
  8. Hit "Apply", and save the profile as "QEMU Profile" using "Save as ..." (upper right)
Koelsch
  1. Choose "Preferences" from the "Windows" menu to display the Preferences Dialog.
  2. Click "Yocto Project ADT"
  3. Choose "Standalone pre-built toolchain" under "Cross Compiler Options".
  4. Point to "$HOME/gdp-sdk/koelsch" (expand $HOME while you do it) as "Toolchain Root Location.
  5. Point to "$HOME/gdp-sdk/koelsch/sysroots" (expand $HOME while you do it) as "Sysroot Location.
  6. Choose "External HW" under "Target Options"
  7. Save the profile as "Koelsch Profile" using "Save as ..." (upper right)


Before leaving the "Preference" dialog make sure to select the "Standard Profile", which should be equal with the "QEMU Profile", then hit "OK".

Test HelloWorld project

Create Eclipse Project

You can create two types of projects: Autotools-based, or Makefile-based. This section describes how to create Autotools-based projects from within the Eclipse IDE. For more information including information on creating Makefile-based projects in a terminal window, see the section "Using the Command Line" in the Yocto Project Application Developer's Guide.

  1. Select "Project" from the "File -> New" menu.
  2. Double click "C/C++".
  3. Double click "C Project" to create the project.
  4. Expand "Yocto Project ADT Autotools Project".
  5. Select "Hello World ANSI C Autotools Project". This is an Autotools-based project based on a Yocto template.
  6. Put a name in the "Project name:" field (top of dialog). Do not use hyphens as part of the name.
  7. Click "Next".
  8. Add information in the Author and Copyright notice fields.
  9. Be sure the License field is correct.
  10. Click "Finish".
  11. If the "open perspective" prompt appears, click "Yes" to switch into the C/C++ perspective.
  12. The left-hand navigation pane shows your project. You can display your source by double clicking the project's source file.

To see the environment variables created during setup, go to Project > Properties > C/C++ Build > Environment.

Building the Project

To build the project, select "Build Project" from the "Project" menu. The console should update and you can note the cross-compiler you are using.

Qt5 SDK and Qt Creator

This section describes how to setup Qt5 development environment for cross compilation with the Qt Creator

Qt Creator Download and Install

  1. Download QtCreator 3.2.2 or later.
  2. Once you downloaded check the file integrity:
    $ cd $HOME/Downloads
    $ sha256sum qt-creator-opensource-linux-x86_64-3.2.2.run 
    ea8d0e1b4afdc47c29216154234ef3371586ff1d5e37ec85096d1d5f0f6aeaef  qt-creator-opensource-linux-x86_64-3.2.2.run
    

    Compare the result (ea8d0e1b4a ...) with the SHA256 value documented under the Qt Creator Info link (SHA-256 Hash: ea8d0e1b4afdc47c29216154234ef3371586ff1d5e37ec85096d1d5f0f6aeaef).

  3. Make the downloaded file executable and execute it.
    $ cd $HOME/Downloads
    $ chmod a+x qt-creator-opensource-linux-x86_64-3.2.2.run
    $ ./qt-creator-opensource-linux-x86_64-3.2.2.run
    
  4. Follow the on-screen directions given by the Qt Creator Installer.
    • Specify "$HOME/gdp-sdk/qtcreator-3.2.2" as the folder where Qt Creator will be installed.
    • Do not launch Qt Creator at the end as suggested by the Qt Creator Installer.

Qt Creator Setup

Qt Creator Launch (QEMU)
  • If you want to use Qt Creator with the QEMU virtual machine, use this command to execute the Qt Creator.
    $ cd $HOME/gdp-sdk/qemux86-64
    $ source ./environment-setup-core2-64-poky-linux
    $ cd $HOME/gdp-sdk/qtcreator-3.2.2/bin
    $ ./qtcreator
    
Qt Creator Launch (KOELSCH)
  • If you want to use Qt Creator with the Renesas Koelsch board, use this command to execute the Qt Creator.
    $ cd $HOME/gdp-sdk/koelsch
    $ source ./environment-setup-cortexa15hf-vfp-neon-poky-linux-gnueabi
    $ cd $HOME/gdp-sdk/qtcreator-3.2.2/bin
    $ ./qtcreator
    

Qt Creator Configuration

So the Qt Creator uses the correct tool chain you need to configure the Qt Creator tool. The following sequence, especially the pictures, explain the configuration to be used for the Renesas Koelsch board. Adapt the path in accordance to the machine you plan to build for, for example QEMU. Please have the device up and running before you start the Qt Creator Configuration steps, as the (SSH) connectivity to the target device will be tested by the Qt Creator.

Add Device

After install procedure was done, select "Tool - Options - Devices" then add QEMU (192.168.7.2) or Koelsch Board (192.168.1.2).
User and Password is 'root' (without the quotes).

Add Cross Compiler

  1. Select "Tool - Options - Build & Run - Compilers"
  2. Click Add Button and select GCC
  3. Enter the Compiler name "GCC (qemux86-64)" or "GCC (koelsch)" in the "Name" field
  4. Add cross compilers path in "Compiler path" field
    • GCC Path Example (KOELSCH): $HOME/gdp-sdk/koelsch/sysroots/x86_64-oesdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi-gcc
    • GCC Path Example (QEMU): $HOME/gdp-sdk/qemux86-64/sysroots/x86_64-oesdk-linux/usr/bin/x86_64-poky-linux/x86_64-poky-linux-gcc
  5. Click Apply button
Qt Versions setting

In case you followed the previous steps, this step may be optional in case Qt Creator may have found "qmake" already in $PATH.

  1. Select "Tool - Options - Build & Run - Qt Versions"
  2. Click "Add" button to open file browser popup
  3. Browse & select "qmake" file and click "Open" button
    • qmake path Example (QEMU): $HOME/gdp-sdk/qemux86-64/sysroots/x86_64-oesdk-linux/usr/bin/qt5/qmake
    • qmake path Example (KOELSCH): $HOME/gdp-sdk/koelsch/sysroots/x86_64-oesdk-linux/usr/bin/qt5/qmake
  4. Change the Name if you want to.(Optional)
  5. Click Apply Button
Debugger setting

  1. Select "Tool - Options - Build & Run - Debuggers"
  2. Click "Add" button
  3. Click "Browse" button and select gdb file and click "Open" button. The gdb file path should be the same as the Compiler file path.
    • GCC Path Example (QEMU): $HOME/gdp-sdk/qemux86-64/sysroots/x86_64-oesdk-linux/usr/bin/x86_64-poky-linux/x86_64-poky-linux-gdb
    • GCC Path Example (KOELSCH): $HOME/gdp-sdk/koelsch/sysroots/x86_64-oesdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi-gdb
  4. Change the "Name" to "GDB (qemux86-64)" or "GDB (KOELSCH)"
  5. Click the "Apply" button
Add new Kits

  1. Select "Tool - Options - Build & Run - Kits"
  2. Click the "Add" button
  3. Enter the Kits name, either "qemux86-64" or "koelsch", in the "Name" field
  4. Select "Generic Linux Device" type in "Device type" field
  5. Select one of the previously created devices ("QEMU" or "Koelsch Board") from the "Device" drop-down.
  6. Select a compiler that you added previously ("GCC (qemux86-64)" or "GCC (koelsch)") from the "Compiler" drop-down.
  7. Select a debugger that you added previously ("GDB (qemux86-64)" or "GDB (koelsch)") from the "Debugger" drop-down.
  8. Select Qt version that you added previously ("Qt 5.3.2 in PATH (qt5)") from the "Qt Version" drop-down.
  9. Click the "Apply" button.