Skip to end of metadata
Go to start of metadata

meta-ivi (GENIVI Yocto Baseline) 9.0 release

Software Base

  • Yocto Project (poky)
    • Linux Kernel 3.14.36

Layer Dependencies

URI:git://git.yoctoproject.org/poky
branch:fido
revision:eb4a134a60e3ac26a48379675ad6346a44010339
URI:git://git.openembedded.org/meta-openembedded
branch:fido
revision:5b0305d9efa4b5692cd942586fb7aa92dba42d59

Supported Hardware

The following hardware platforms are supported:

QEMU (ARMv7) —emulated machine: vexpressa9
QEMU (IA-32) —emulated machine: qemux86
QEMU (x86-64) —emulated machine: qemux86-64

Check out the baseline for building

% mkdir $HOME/genivi-baseline
% cd $HOME/genivi-baseline
% git clone git://git.yoctoproject.org/poky
% cd poky; git checkout eb4a134a60e3ac26a48379675ad6346a44010339; cd -
% git clone git://git.openembedded.org/meta-openembedded
% cd meta-openembedded; git checkout 5b0305d9efa4b5692cd942586fb7aa92dba42d59; cd -
% git clone git://git.yoctoproject.org/meta-ivi
% cd meta-ivi; git checkout 9.0.0; cd -

How to build and run?

Build and run a QEMU image including GENIVI P1 components from source

You can build and run a QEMU image including GENIVI P1 and some P2 components using the steps provided in the README.md from the meta-ivi 9.0.0 tag.

meta-ivi 9.0.0 metadata

The meta-ivi 9.0.0 metadata has been sent to the meta-ivi mailing list.
The meta-ivi-9.0.0_metadata.7z archive that is attached to that email should have the following contents:

Package Manifest :[ARMv7][IA-32][x86-64] package.manifest
License Manifest :[ARMv7][IA-32][x86-64] license.manifest
Human-readable information about the build configuration and metadata source revisions :[ARMv7][IA-32][x86-64] build-id
graphviz-compatible dependency graphs for the image :[ARMv7][IA-32][x86-64] depends.dot
A list of files in the image with permissions, owner/group, size, and symlink information :[ARMv7][IA-32][x86-64] files-in-image.txt
A text file containing name-value pairs with information about the image :[ARMv7][IA-32][x86-64] image-info.txt
A list of installed packages (names only) :[ARMv7][IA-32][x86-64] installed-package-names.txt
A list of installed packages ordered by size :[ARMv7][IA-32][x86-64] installed-package-sizes.txt
A list of installed packages (full package filename) :[ARMv7][IA-32][x86-64] installed-packages.txt

changes from 8.0.1

Package NameVersionDifference from previous version
AudioManagerController7.0meta-ivi
audiomanager7.0meta-ivi
ofono1.16poky, meta-ivi
bluez5.28poky, meta-ivi
bluez5.28poky, meta-ivi
bluez5.28poky, meta-ivi
bluez5.28poky, meta-ivi
wayland, weston1.6.0poky, meta-ivi/meta-ivi-bsp, meta-ivi
wayland-ivi-extension1.3.91meta-ivi
glibc2.21poky
neard0.15poky, meta-ivi
mesa10.4.4poky, meta-openembedded
persistence-administrator1.0.5meta-ivi
persistence-client-library1.0.0(meta-ivi: no change)
ofono1.16poky, meta-ivi
alsa-lib1.0.28poky
alsa-utils1.0.28poky
audiomanager7.0meta-ivi
dlt-daemon2.11.1(meta-ivi: no change)
connman1.28poky, meta-ivi
dbus1.8.10poky
fuse2.9.3(meta-openembedded, meta-ivi: no change)
gstreamer1.4.5poky
common-api-runtime3.1.3meta-ivi
common-api-dbus-runtime3.1.3meta-ivi
curl7.40poky
libusb11.0.19poky
linux-yocto3.14.36poky/meta-yocto-bsp, poky/meta-skeleton, poky/meta, meta-openembedded
node-health-monitor1.3.5(meta-ivi: no change)
node-startup-controller1.0.2(meta-ivi: no change)
node-state-manager2.0.0(meta-ivi: no change)
openssl1.0.2apoky
pulseaudio6.0poky, meta-ivi
sqlite3.8.7.4poky
systemd219poky
wpa-supplicant2.3poky

 

Copied from MediaWiki
Last Updated: 12:52, 7 October 2015‎ Min-su.Kim

  • No labels